Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[tlug] Accessing microphone (was a bunch of other topics about sound and modules) [SOLVED]



After all the confusion with drivers and cards and whatnot, it turned out that one simple setting solved it all.

A person on the Ubuntu mailing list advised that all that was happening was that the two different drivers for the sound card were just different methods of controlling the card - ALSA and OSS. ALSA is the more modern one and I should just focus on that.

In the Gnome Volume Control Panel, under File | Change Device..., I selected "HDA Intel (Alsa mixer)". I think that by setting it there, then that's the device and driver that will be used system wide.

In the same Volume Control interface, there are are tabs called "Playback", "Capture", and "Switches". Under the "Capture" tab, there are three capture devices, called "Capture", "Capture1", and "Capture2". Underneath each is a little icon of a speaker, and a little icon of a microphone. The microphone has a little red X over it. By clicking on the microphone under the first one marked "Capture", the red X is removed.

After that, it was smooth sailing. I was able to record my voice in Audacity. And then I was able to use the microphone within my virtual Windows, where I was able to connect with my dad in Yahoo! Messenger and have a voice conversation.

So it looks like I have got full functionality from my sound device, and I can now look into VOIP options like Ekiga and whatnot.

I don't remember seeing this particular capture before, despite hunting around, so maybe it was one of the driver installations or kernel upgrades or something that made it available. Or maybe it was always there and I missed it. Who knows. In any case, I'm glad to have it working.

Thanks everyone for the help, information, and advice.

Dave M G

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links