Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[tlug] modprobe.conf (was: Accessing microphone)


After my last reboot, I've lost the Realtek sound device.

Turns out, that all that was in my /etc/modprobe.conf file was this one line:
Cannot find old version of modprobe. Giving up.

So I tried to go back and run the generate-modprobe.conf shell script, but it said the same thing again.

At this point I realized I didn't know what this modprobe.conf is supposed to do for me. So I looked it up on Google and it seems to have a lot to do with all sorts of devices, like net cards and video cards and various other things.

So while I don't understand what it does, I do understand that I have an old version of it, called modules.conf, on the CD that came with the Linux drivers for my sound card (integrated with my motherboard).

I tried using generate-modprobe.conf to convert that old modules.conf file to a proper modprobe.conf, but it only ever generates files that say "Cannot find old version of modprobe. Giving up."

I've included the contents of the old modules.conf file below.

But I'm stuck on not only how to do this, but what it is I'm trying to do. Aren't I simply trying to install a driver for this sound card? How come it's not a matter of downloading a repository package, like I did for my video card, or getting some kind of tar.gz and doing a make/install process like I've done for other things?

What is it about installing this sound driver that has raised the level of complexity? What the heck is a modprobe.conf file supposed to do for me?

- - -

Below the modules.conf file is some odd error output that happened for no apparent reason.

- - -

Here is the modules.conf file included on the CD:

#alias sound-slot-0 via82cxxx_audio //remark this line, this is default audio driver

#====== added those lines =============
alias char-major-116 snd
options snd major=116 cards_limit=1
# -- Azalia controller -----------------------------
alias snd-card-0 snd-azalia
options snd-azalia index=0 id="Azalia"
#--- Intel 8x0  , SiS 7012 and NVidia----------
#alias snd-card-0 snd-intel8x0
#options snd-intel8x0 index=0 id="ICH"
#--- Via8233 Via686a  -------------------------------
#alias snd-card-0 snd-via82xx
#options snd-via82xx index=0 id="VIA"
#--- ATI  -------------------------------
#alias snd-card-0 snd-atiixp
#options snd-atiixp index=0 id="ATI"
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || : pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :

- - -

Here is the strange error output that seemed to magically happen in a terminal window. I was running "gedit" at the time, so I don't even know what triggered this:

ALSA lib confmisc.c:672:(snd_func_card_driver) cannot find card '0'
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_card_driver returned error: No such device
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_concat returned error: No such device
ALSA lib confmisc.c:1072:(snd_func_refer) error evaluating name
ALSA lib conf.c:3493:(_snd_config_evaluate) function snd_func_refer returned error: No such device
ALSA lib conf.c:3962:(snd_config_expand) Evaluate error: No such device
ALSA lib pcm.c:2102:(snd_pcm_open_noupdate) Unknown PCM default

Dave M G

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links