Mailing List Archive

Support open source code!

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tlug: Re: libwcsmbs

"Eric S. Standlee" wrote:

> I installed a libwcsmbs package off the ftp server and it
> killed my system.  On boot it (init?) would lock up saying something
> about an undefined variable related to libwcsmbs.  This may portray my
> lack of experience in the shared library portion of linux, but as many
> times as I tried to use the rescue disk to go in and remove the libwcsmbs
> files from /lib, /usr/lib, and some X11R6/lib directory, it popped up
> again and I ended up reinstalling RH6.0
> I am baffoozled.  Any help?
> Eric

Hi Eric,

Seems too late, but I've got same problem as you some time ago, trying to
'japanize' my redhat 6.0 installation, and I could recover without reinstalling

I installed libwcsmbs package, and -guess what- my system would boot any more.
Hopefully, I had a rescue disk, so I could go around my system, and I finally
found that the file /etc/ mentioned the library (I
don't remember path), among others.
As far as I understand, the system tried to load this library before running any
command. Since it is incompatible with new glibc, I couldn't run anything.
So, the cure was :
    - boot with rescue disk
    - in /etc/, remove the line with libwcsmbs
    - sync, reboot normally
    - remove the package.... rpm -e libwcsmbs


Next Technical Meeting: October 9 (Sat), 13:30   place: Temple Univ.
* Linux Internationalisation Initiative (Li18nux) speaker: Akio Kido
* Japanese TrueType Fonts                     speaker: Adrian Havill
Next Technical Meeting: November 13 (Sat), 13:30 place: Temple Univ.
* Network Security                               speaker: Steve Baur
Next Nomikai:  December 17 (Fri), 19:00 Tengu TokyoEkiMae 03-3275-3691
more info:        Sponsor: Global Online Japan

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links