Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [tlug] running exim4 as alternate user?

Hi everyone,

On Tue, 2007-04-10 at 11:58 +0900, Keith Bawden wrote:
> So, somewhere in the exim configs there should be "user" and "group"
> options to run as.

Didn't have any luck finding this in /etc/exim/exim.conf. I tried
changing the owner of the exim binary and running as a different user,
but that of course didn't work. Then I tried changing the suid of the
binary thinking it would run as the new owner, still no go. What was
unfortunate was that while fiddling around with exim, for some reason I
had removed the suid bit and failed to replace it afterwords. I hadn't
received any mail for a few hours and was getting suspicious. Checking
the logs I found that exim wasn't able to route mail due to permissions
problem, so I reset the suid on the exim binary, restarted it, and mail
worked again. Just in case anyone else ever has this problem, you can
flush the frozen mail from the exim queue using:
exim -qff     

So I'm back to square one. I guess I'll just recompile mailman. Probably
would have been easier in the first place.

Scott VanDusen

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links