Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [tlug] Japanese Input on CentOS / KDE

Hash: SHA1

On Sat, Aug 13, 2005 at 02:23:05AM +0900, Dave Gutteridge wrote:
> Scott,

> Okay, I removed my file from the Autostart directory, restarted my 
> session, then started a kterm with the commands:
> [ ~]$ kinput2 -canna &
> [1] 5519
> [ ~]$ XMODIFIERS='' LC_CTYPE=ja_JP.eucjp kterm
> ... and vi worked fine. No wacky kanji, everything worked smooth as silk.
> And, by starting FireFox and Thunderbird from the command line, I got Japanese 
> input there too:
> ここも日本語を書くことが出来るよ!
> (I hope that doesn't come out as mojibake on your screen. Thunderbird complains 
> when I send it that it's not UTF. But at least when I type it, it works okay.)

Came out fine in a terminal that uses euc.  :)  It also came out without
problem in urxvt which does UTF-8.  So, that was fine.

> Okay, so it looks like something isn't kosher with the file, or how 
> it's being called. Just to verify, here are the contents:
> #!/bin/sh
> kinput2 -canna &

Which looks fine to me.  Do you boot up in text mode and start X with
startx, or do you boot into KDE directly. If the former, you can add
these to one of your .xinit files--IIRC, it didn't work in .xinitrc with
RH, I had to put it in .Xclients or something like that. 

So, that's the next question, do you boot in text or GUI mode?

- -- 


GPG KeyID EB3467D6
( 1B848 077D 66F6 9DB0 FDC2  A409 FA54 D575 EB34 67D6)
gpg --keyserver --recv-keys EB3467D6

Giles: In be must perform the a tutu. Pillock!
Angel: All right, someone get the chain saw.
Version: GnuPG v1.4.2 (FreeBSD)


Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links