Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [tlug] Japanese Input on CentOS / KDE


    Thank you for continuing to work through this with me.

    Okay, the /home/dave/.kde/Autostart directory was already there, so 
I went in and created a file called "".
    In it, I put:

kinput2 -canna &

    Then I made it executable (chmod 755).

    Now, before I continue, I noticed that after I did this, I saw 
another file in the directory called "". I opened it with an 
editor to see what was inside, and it was the same as my "" 
file. I thought it might be a temp file created by my kedit text editor, 
but it didn't go away when I closed kedit. I deleted it, though, as I 
thought it was strange and upsetting. I re-verified that my original 
"" had the right content and permissions, then, moving on:

    I logged out, restarted X just for good measure, and logged back in. 
If I understand Linux correctly, I shouldn't have to reboot. And...

    The results I'm afraid are not good. In a fit of excitement, I 
opened up Thunderbird to see if I could type Japanese in an email 
window. No go. Shift+space had no result, except to move my cursor.
    Then I went to Firefox to see what might happen there. Same deal.

    So then I opened a kterm window, and vi, to see if that worked. And, 
here's where it gets sticky. By going into vi, and making sure I'm in 
"insert" mode by pressing "i", I get Japanese input by pressing 
shift+space. Just like before, so that's promising.
    But, beyond that, it's all wonky. I tried typing in "jikan", just as 
an arbitrary word to test it with. When I press space, the correct kanji 
for "jikan" (in this case, I mean it in the sense of "time") come up. 
But then when I hit enter to accept the kanji, instead of being jikan, 
suddenly, the kanji for "son" ("damage", "injure") appears on the left 
of the cursor. Right where the cursor is, and highlighted by the cursor, 
is the kanji for "tan" ("unravel"), and on the right of the cursor is 
the kanji for "sotsu" ("graduate").
    After that, trying to move the cursor to the end of the line or type 
in any more Japanese is just chaos. I repeated the procedure to see if 
these crazy kanji that I was getting were random or not, and they're not 
random. Typing in any word gets the wrong kanji, but it's the same wrong 
kanji each time.
    Well, that's a weird thing to happen. You can imagine me sitting 
staring at the computer screen with question marks popping up above my 
head, like you see happening on Japanese TV.
    Any idea what's up with that?


Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links