Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [tlug] Re: Japanese in Gentoo

On Sat, Jun 29, 2002 at 11:55:57AM +0900, Jack Morgan wrote:
> On Fri, Jun 28, 2002 at 10:40:23PM -0500, Scott Robbins wrote:
> > Hrmm--I just tried unmerging my version (the old one) and
> > re-emerging--same problem as before, it can't find a canna library.
> I just tried on my box and it compiled fine. Try emerge --clean rsync

Hrmm--I already started the reinstall--I'd been planning to do it for
days, so, this was a good excuse--and Naoko's in Boston this weekend,
so it's a good chance.  (oops, just realized this was to t-lug, not
private--oh well, now you all know my wife is in Boston.)  :)
> > This one has kde (which I no longer put in, as I find myself never
> > using it, or anything from it.)  I still think there may be some issue
> > with the qt libraries, as the times when it didn't work were always
> > after putting in KDE.   
> I have USE="-kde -arts"

Sigh--now, I'm tempted to put kde on this box (I'm on another box now,
as I've started the install) just to see if it will work.  I blame you
for this. :)
> > This seems to be the problem
> > 
> > /lib kinput2.o ../lib/libKi2.a ../lib/imlib/libim.a  -lcanna16  -lXaw
> > -lXmu -lXt -lSM -lICE -lXext -lX11 -L/usr/X11R6/lib     
> > /usr/i686-pc-linux-gnu/bin/ld: cannot find -lcanna16
> > collect2: ld returned 1 exit status
> > make[1]: *** [kinput2] Error 1
> > make[1]: Leaving directory
> > `/var/tmp/portage/kinput2-3.1_beta4/work/kinput2-v3.1-beta4/cmd'
> Post more output. I seem to recall you need to do ln -s something but
> can't recall the something. I recon that the above "rsync" should fix it
> though. 

I really should have done that--this heat is a bit ennervating
(enervating?) and I was eager to get the new install started.  Now, I
feel guilty enough so that I'll install KDE on this one. I will then
emerge -C kinput2 and canna. I will then do an emerge --clean rsync and
try to install it from ports--if I still have a problem, I'll post
again--as I'll do if it's fixed.  As this is an experiment, I'm going
to not put in the USE flag about kde-artwork though, and see what

I apologize to both you and Ryan for not taking the time to wait for
suggestions before starting the new installation--it was fairly stupid
on my part.  My penance will be installing kde-base on this box.  (I
refuse that other suggested penance, aol help desk, whether or not it
matches my level of competence.)
> Also post a find / -name "*canna*" -print output  

Will do if after the kde build, the kinput build fails.

Again my apologies--even more so to Ryan (although Ryan, I do mention
your successful ebuild on other heavily popoulated lists, such as NYLUG
and others.)

Scott (from NY)

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links