Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [tlug] Re: Japanese in Gentoo

On Sat, Jun 29, 2002 at 11:08:36AM +0900, Shaw wrote:
> On Sat, 2002-06-29 at 02:48, Scott Robbins wrote:
> > The reason I say don't use the official ebuild--the kinput2 isn't
> > official yet, as far as I know, and the one that Ryan made is looking
> > for canna in /usr/portage/app-misc--
> Actually, kinput2 has made it to the official tree, 
> finally. Both kinput2 and canna can be found in 
> app-i18n.
> Note: the kinput2 ebuild builds a kinput2 with canna
> support ONLY. I don't use Wnn or any of the others,
> and didn't want to make ebuilds for software I don't
> use or know well.
> There is an ebuild for a canna/Wnn-enabled kinout2
> in gentoo's bugzilla (that someone else wrote). Not 
> sure if this will become two separate kinput2 ebuilds, 
> or one merged ebuild.
> Finally--the problems some people had installing,
> though never completely solved, seemed to be due to
> some missing /usr/X11R6/lib/X11/config/* files, 
> needed for xmkmf (cross-platform build system used
> by canna and kinput2) to work correctly. I believe 
> Jack told me he had accidentally removed X from his 
> USE vars at one point, which may have had something 
> to do with it.

Hrmm--I just tried unmerging my version (the old one) and
re-emerging--same problem as before, it can't find a canna library.

I think for the moment, I'm going to stand by my advice to emerge it
immediately after emerging X.  

I did on this install, since I've put so much extra junk in this one
that I was planning to redo it from scratch anyway.  :)

This one has kde (which I no longer put in, as I find myself never
using it, or anything from it.)  I still think there may be some issue
with the qt libraries, as the times when it didn't work were always
after putting in KDE.   

This seems to be the problem

/lib kinput2.o ../lib/libKi2.a ../lib/imlib/libim.a  -lcanna16  -lXaw
-lXmu -lXt -lSM -lICE -lXext -lX11 -L/usr/X11R6/lib     
/usr/i686-pc-linux-gnu/bin/ld: cannot find -lcanna16
collect2: ld returned 1 exit status
make[1]: *** [kinput2] Error 1
make[1]: Leaving directory

Then, the same thing that I wrote about privately, that it doesn't
install the application.

Despite this problem, I still think you did a great job--when I
install it shortly after installing X it works absolutely perfectly


> Anyway, if anyone has problems installing it please
> post your problems at   

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links