Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [tlug] Re: Japanese in Gentoo

On Fri, Jun 28, 2002 at 10:40:23PM -0500, Scott Robbins wrote:
> Hrmm--I just tried unmerging my version (the old one) and
> re-emerging--same problem as before, it can't find a canna library.

I just tried on my box and it compiled fine. Try emerge --clean rsync
> This one has kde (which I no longer put in, as I find myself never
> using it, or anything from it.)  I still think there may be some issue
> with the qt libraries, as the times when it didn't work were always
> after putting in KDE.   

I have USE="-kde -arts"

> This seems to be the problem
> /lib kinput2.o ../lib/libKi2.a ../lib/imlib/libim.a  -lcanna16  -lXaw
> -lXmu -lXt -lSM -lICE -lXext -lX11 -L/usr/X11R6/lib     
> /usr/i686-pc-linux-gnu/bin/ld: cannot find -lcanna16
> collect2: ld returned 1 exit status
> make[1]: *** [kinput2] Error 1
> make[1]: Leaving directory
> `/var/tmp/portage/kinput2-3.1_beta4/work/kinput2-v3.1-beta4/cmd'

Post more output. I seem to recall you need to do ln -s something but
can't recall the something. I recon that the above "rsync" should fix it
Also post a find / -name "*canna*" -print output

Jack Morgan						<> 
GnuPG Key ID: 0x620F545F

Attachment: pgp00033.pgp
Description: PGP signature

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links