Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[tlug] Package dependency problems

(was: something about Printer ... [SOLVED], but it isn't! Reminder: I'm trying to install a Canon printer driver under Ubunbu)

Dave M G wrote:

Glad my printer instructions were of some help, even if they haven't gone quite right for you.

Thanks for the feedback. The reason I mentioned getting a different printer was the stuff I found at where Canon are down at the bottom of the pile. Since they practically give the printers away in the hope of selling ink, it might be quicker to just buy a printer from a linux-cooperative mfr, from whom I'd prefer to buy ink anyway.

But meanwhile...

I tried all over again, and also tried with Synaptic, but still get the same error messages:

bjfilter-2.5: Depends: libc6 (>= 2.4-1) but 2.3.6-0ubuntu20 is to be installed
pstocanonbj: Depends: libc6 (>= 2.4-1) but 2.3.6-0ubuntu20 is to be installed
Depends: libcupsys2 (>= 1.2.3) but 1.2.2-0ubuntu0.6.06 is to be installed

This seems to mean that the printer driver(s) need a later version of the C library than the one "to be installed". But I don't understand why
a later one couldn't be "to be installed". Is this an upgrade decision I have to make myself.

I'd be grateful for any help - I am very much a beginner at this admin stuff - at least I can make some sense of the messages even if I can't understand them, and it's a great improvement over the "Installation completed successfully" (but it doesn't work) syndrome.

Brian Chandler

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links