Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [tlug] Printer Not Responding [SOLVED]

(Excuse top-post pre-message...)

I've been lurking here for some time, in fact I managed to lurk at a TLUG nomikai too, but this is my first post. Yoroshiku!

Dave M G wrote:

Here's a blast from the past. This thread had gone on for ages without a solution, despite a great deal of help from the TLUG list. It only stopped because I gave up trying to make it work. As far as I was concerned, my printer was basically not going to work with Ubuntu Dapper, period.

Hmm, my situation... I have a Canon printer, and thought I would give it a third try with the following instructions...

How to install a Canon printer in Ubuntu (as of January 17, 2007):

1. Go to CUPS interface in browser:


2. Delete any printers there. (This was necessary on my system as I had drivers from previous versions of Ubuntu/CUPS that had never worked.)

3. If asked for any passwords, use the login and password that are for the main account on the computer.

4. The instructions after this point were originally from the following web site, and modified here for my particular case:

5. Open a command prompt. Edit the repository list here:

sudo gedit /etc/apt/sources.list

6. Add the following line. This is specifically for Ubuntu (It also says for Edgy, 6.10, but may work for other Ubuntu versions):

deb ./

7. Update apt-get to use the new repository information:

apt-get update

8.Use the following install command:

sudo apt-get install libcnbj-2.5 bjfilter-2.5 pstocanonbj

Got that far. Then I got the following problem (at the end)...

Get:1 dapper Release.gpg [189B]
Get:2 dapper-updates Release.gpg [191B]
Ign ./ Release.gpg
Hit dapper Release
Get:3 edgy Release.gpg [189B]
Get:4 dapper-security Release.gpg [191B]
Get:5 dapper-updates Release [50,9kB]
Get:6 dapper-commercial Release.gpg [191B]
Ign ./ Release
Ign ./ Packages
Get:7 dapper-backports Release.gpg [191B]
Get:8 dapper-updates Release.gpg [191B]
Get:9 dapper-security Release.gpg [191B]
Get:10 dapper Release.gpg [189B]
Get:11 dapper Release.gpg [189B]
Get:12 dapper-commercial Release [4886B]
Get:13 dapper-security Release [50,9kB]
Get:14 ./ Packages [1433B]
Get:15 edgy Release [6733B]
Hit dapper-backports Release
Get:16 dapper-updates Release [50,9kB]
Get:17 dapper-commercial/main Packages [2645B]
Get:18 dapper Release [8412B]
Hit dapper/main Packages
Hit dapper/restricted Packages
Hit dapper/main Sources
Hit dapper/restricted Sources
Get:19 dapper-security/main Packages [105kB]
Get:20 edgy/main Packages [5659B]
Hit dapper/universe Packages
Hit dapper/universe Sources
Get:21 dapper-updates/main Packages [138kB]
Get:22 dapper/main Packages [532B]
Get:23 dapper-security Release [50,9kB]
Ign dapper-security Release
Hit dapper Release
Hit dapper-backports/main Packages
Hit dapper-backports/restricted Packages
Hit dapper-backports/universe Packages
Hit dapper-backports/multiverse Packages
Get:24 dapper-updates/universe Packages [22,4kB]
Get:25 dapper-security/restricted Packages [7250B]
Get:26 dapper-updates/multiverse Packages [1805B]
Get:27 dapper-updates/restricted Packages [14B]
Get:28 dapper-security/main Packages [105kB]
Get:29 dapper-updates/main Sources [49,5kB]
Get:30 dapper-security/main Sources [20,9kB]
Get:31 dapper-security/restricted Sources [983B]
Get:32 dapper-security/restricted Packages [7250B]
Get:33 dapper-security/universe Packages [53,4kB]
Get:34 dapper-updates/restricted Sources [14B]
Get:35 dapper-security/multiverse Packages [4082B]
Hit dapper/multiverse Packages
Fetched 700kB in 1m50s (6339B/s)
Reading package lists... Done$ sudo apt-get install libcnbj-2.5 bjfilter-2.5 pstocanonbj
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  bjfilter-2.5: Depends: libc6 (>= 2.4-1) but 2.3.6-0ubuntu20 is to be installed
  pstocanonbj: Depends: libc6 (>= 2.4-1) but 2.3.6-0ubuntu20 is to be installed
               Depends: libcupsys2 (>= 1.2.3) but 1.2.2-0ubuntu0.6.06 is to be i nstalled
E: Broken packages

Help! I did press on and try, without luck - the only Canon driver that appeared even close was "Canon PIXMA iP4000 - CUPS+Gutenprint v5.0.0-rc2" - I actually have a PIXUS iP1500.

Can anyone tell me how to make this work?

Or should I just go and buy a printer from a Linux-friendly company? Are there any specific reccomendations for printers to buy *in Japan*?

(I'll leave the rest of the instructions below - step 15 produced silence as usual.)

Brian Chandler

9. Note that this will restart CUPS.

10. Go to CUPS interface in browser:> http://localhost:631/

11. Add a printer by clicking the "Add Printer" button.

12. Name, location, and description are all just whatever you want to call them. These are names for the user's convenience, not important system variables. I used:

Name: Canon
Location: Desktop
Description: Canon Pixus iP3100

13. In the Device drop down menu, select the printer that matches yours. If all is going well, something fairly obvious should present itself. In my case, I chose:

Canon iP_3100 USB #1 (Canon iP_3100)

14. Select a driver from the list. I chose:

Canon PIXUS iP3100 Ver.2.50 (en)

15. Print a test page!

Dave M G
Ubuntu 6.10 Edgy Eft
Pentium D Dual Core Processor
PHP 5, MySQL 5, Apache 2

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links