Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: scim/Arch oddness (was Re: [tlug] Japanese page has been revised)

Hash: SHA1

On Wed, Aug 17, 2005 at 08:44:51PM -0600, Matt Gushee wrote:
> Scott Robbins wrote:
> >At any rate, if the pacman packages don't work, just get the three
> >source ones that I list there, and install them.  It works perfectly.
> Except that, in my curmudgeonly way, I insist on installing all non-distro 
> packages under /opt/<package> ;-) So ./configure failed for scim-anthy ... 
> claimed it couldn't find anthy/anthy.h, no matter how hard I tried to tell it.

I believe you said in an earlier post that you are stubborn.  I admit
that made me snicker when I read it.  Yes, it does seem choosy about
that, I'm putting everything in /usr/bin, just following the path of
least resistance. 

> But then I gave the Arch binaries another try, and noticed something 
> interesting:
>   1) $ scim -d  *appears* to fail. Doesn't seem to do anything from
>      .xinitrc (actually .Xclients, but that's more-or-less the same).
>      So then I try it in an RXvt, and it prints an error message saying
>        Failed to load x11 FrontEnd module.
>        Failed to launch SCIM.
>   2) But if I subsequently launch a GTK app from the same terminal window
>      (does it have to be the same one? not sure yet), a SCIM widget
>      appears in the corner of the screen, and Japanese input is available
>      for that app.
> Weird, huh?

However, I didn't get it working with very many apps--actually, I got
the error message you mention--sigh, let me look for the bug Damir
posted, hold on.

Yes, did I mention that if one does the socket thingie, it does start?
At that point I got it working with Abiword, but I think that was about

> It kind of looks as if you need to have some GTK/Gnome stuff running on your 
> desktop (with LANG set to ja_JP.*, maybe?) for SCIM to start up. I run a really 
> minimal desktop (windowlab, nice wallpaper, that's about it--no G-anything, 
> until I want to actually use a GTK program).

Yes, today, after getting more and more irked about it not working in
Vector but working in Slack and ZenWalk, I made a list of packages
installed in ZenWalk but not vector--there were several gnome ones. 

HOWEVER--on a relatively minimal Arch install, the downloaded packages
(if you're not silly enough to try to get them into /opt--I've never
liked /opt, I guess that's the BSD-er in me)  :) work in any program.

- -- 

Scott Robbins

PGP keyID EB3467D6
( 1B48 077D 66F6 9DB0 FDC2 A409 FA54 EB34 67D6 )
gpg --keyserver --recv-keys EB3467D6

 Joyce: But maybe, we could spend some time together soon? Some night
when I'm not being held hostage by a raving psychotic.
Version: GnuPG v1.4.2 (FreeBSD)


Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links