Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [tlug] No video playback in Iceweasel

On 11/27/2014 08:04 PM, Stephen J. Turnbull wrote:
CL writes:

  > I've tried killing all add-ons and just starting the video players, then
  > adding the add-ons back one at a time to see which one is killing the
  > video, but the video doesn't start with all other add-ons turned off,
  > either.

Start from the command line and see what warnings/errors you get.
Warning: any GTK application is likely to spew so many uninterpretable
warnings you'll think you have cat'ted core dump.

  > I've tried completely stripping Iceweasel from the HDD and installing
  > just the video players but that hasn't led anywhere, either.

Well, no, I wouldn't expect your monitor to suddenly morph into a bus
guide complete with 5-octaves higher than normal voice and a little
flag, to be honest.  What do you mean by "not lead anywhere"?  Text of
misleading error messages would be really nice, maybe someone has seen
them before.  (Maybe the author of the confusing error message is
watching.  Wouldn't that be cool?!)

Any OS upgrades recently?  What are your SELinux and kernel capability

Apparently, the correct answer to solving the problem is "Send a message to TLUG."

Short story long, before I could try any of the above, I re-checked the settings of every installed add-on I have to see if there were any possible conflicts that I'd missed before. Didn't see anything obviously in conflict.

I then re-checked my super compact theme* settings and found that the programmer who'd designed it had posted a Mk. II version two days ago. He hadn't upgraded the existing design because he'd built a new coding template that he thinks will automatically follow changes that Mozilla adds on the fly. So, I installed the new version and all of my playback problems went away -- on Cnet, Stratfor, Gizmag, ThinkGeeks ... and the two dozen, or so, other sites I tried before writing this mea culpa.

Anyway, I tried the Good Doctor's command line start and got no relevant error messages. At all. The messages I _did_ get had nothing to do with any of this and were actually things I know how to fix, and did.

So, I decided to pop the top on a Heineken and call it fixed.

To answer Travis, in it's last incarnation, I was seeing black rectangles where the video should have been. When I permitted content from video providers (I use extremely strict initial NoScript settings and permit only what is absolutely needed on a page-by-page basis) I would occasionally see the turning arrow or the circle of dots that indicated content loading but then the box would go black again and all activity would stop. Prior to that, there were a couple of other incarnations in which the progress bar would appear across the bottom a'la You Tube, and sound would play but no picture was seen. This morphed into the first condition described above.

* Metal Lion Australis Tiger, now Metal Lion Australis Tiger SP (programmer's name is Frank Lion, hence the hinky name). On my 27型 screen running in 1080P mode, it was good for an extra 2cm, or so, of vertical space over Default Theme. Am also using Classic Theme Restorer and The Addon Bar (restored) which allow the elimination of one entire toolbar on top without losing any information.


Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links