Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[tlug] japanese fonts in ghostscript

ghostscript and japanese fonts are driving me crazy... i have done all 
sorts of reading, and tried a bunch of things things with very limited 
I don't have any problems with japanese text when I create postscript 
from apps like openoffice.
It is when I try to make my own postscript file with perl that i run 
into problems...
I followed the directions on this page ->
and now i can use /WadaMin-Regular-EUC-H  /with / PostScript::Simple, 
/but it won't display any ascii characters. I also tried the same recipe 
with some other fonts from but 
couldn't manage to repeat my initial success.
I fumbled through some other stuff about using truetype fonts and ended 
up adding this line -> /Mona  (/usr/share/fonts/monafont/mona.ttf); to 
Ghostscript now loads this font without any errors,  and if do gs  
/usr/share/ghostscript/8.15/lib/ and then /Mona DoFont,
I get a lovely long list of all the characters i would love to use... 
ascii and kanji, the lot. However, when i try to use Mona with 
/PostScript::Simple  /it only works with ascii characters. I am quite 
sure this has something to do with these CID map things i keep reading 
about... but i really don't know how set them up. All the docs seem to 
be about 4 years old, they talk about patches for 6.something when i 
have 8.15...
Anyway... if someone could please save me from another week of getting 
nowhere and tell me what to do here i would be eternally grateful.
I am not set on using Mona or any font in particular, truetype or type1, 
it would just be really nice to have one basic font that can handle both 
ascii and japanese chars if that is not too much to ask for.


Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links