Mailing List Archive

Support open source code!

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tlug: Apache permission weird.

    I have tried almost all I could do to fix 'permission denied'
problem when I use ~username for Apache1.3.9 bundled with
Turbolinux6.0 but in vain.
    I thought it very strange. The 'srm.conf' in the package given
has the following section.
DocumentRoot "/home/httpd/html"

# UserDir: The name of the directory which is appended onto a user's home
# directory if a ~user request is recieved.

UserDir /home/*/public_html
<Directory /home/*/public_html>
well I fixed this, double checked access.conf
and triple checked httpd.conf as well. I tried even to put
.htaccess in public_html. But nothing changed.

Then I downloaded Apache1.3.12 from
and did make from scratch.
The srm.conf  in this package has the following directives.
I noticed this by diff.
# Control access to UserDir directories.  The following is an example
# for a site where these directories are restricted to read-only.
#<Directory /home/*/public_html>
#    AllowOverride FileInfo AuthConfig Limit
#    Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
#        Order allow,deny
#        Allow from all
#    </Limit>
#        Order deny,allow
#        Deny from all
#    </LimitExcept>
This section cannot be found in the package given for Turbolinux
Server Edition 6.0. But when I took a look at the original Apache
pkg 1.3.9, I could find the section all right. Maybe some errors
or careless mistakes happened while they prepared rpm packages.
I took away those commnents and run httpd, and voila everything
is fine.
Now, everything runs fine. Thanks aplenty.

Selva Nair wrote:

> On Thu, 23 Mar 2000, Yong-Ming Hua wrote:
> >  Hello,
> >     I like to ask about the user permission to Apache server. I have just
> >  installed
> >  Turbolinux Server 6.0 with Apache bundled into one of my ol' machines.
> >
> >  In my access.conf I have got a directive,
> >
> >  order allow,deny
> >  allow from all
> >
> >  and in srm.conf I have got
> >
> >  UserDir public_html
> >
> >  I can see Apache sample.html by its proper name. But I can't see any
> >  file by using ~/username. public_html has a read access all right. And
>                  ^^^^^^^^^^
> should be /~username
> >  of course index.html has the access all right too. But everytime I try
> >  to get the stuff from a user's directory(public_html), I get 'No peremission
> >  to this file/directory'. I havn't got any clue. I have never met this kind
> >  of error-message before. I have checked the history about the proble
> Depending on your default access setup in access.conf you may need
> to specify  allow from all, or whetever access control you need  for
> public_html. Try creating a .htaccess file in $HOME/public_html with
> "allow from all" . If that solves it, review your access.conf to see why
> access is not allowed by default.
> Selva

Office Tel:(Japan)(0)-42-739-8132  Fax:(Japan)(0)-42-739-8847
A Word from YMH CAL LAB : Help those with Terminal Illness
They need your love.

Next Nomikai Meeting: April 20 (Thu) Linux Conference 2000 Spring Ed.
Next Technical Meeting: May 13 (Sat) 13:30 Temple University Japan
* Topic: TBD
more info:        Sponsor: Global Online Japan

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links