Mailing List Archive

Support open source code!

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tlug: "boot partition too big" while installing RH6.1j - part 2

On Sat, 4 Mar 2000, Hector Akamine wrote:

>  I don't know what happened. But my machine stopped freezing during the
>  installation. Linux installed and can run (although I still have some
>  problems).
>  > It is possible that at boot up linux has not sensed the correct values
>  > for cylinders, heads and sectors of your disk. Comparing the linux
>  > fdisk o/p with the specs in your hard disk manual or (printed on your
>  > hard disk itself) may help in diagnosing this.
>  fdisk reports this (when I run it during the installation)
>  disk /tmp/hda: 255 heads, 63 sectors, 2482 cylinders
>  units = cylinder of 16065 * 512 bytes
>  device        boot        start                 end        blocks    id
>  system
>  /tmp/hda1    *          1    1334            10715323+ c    win 95 FAT32
>  (LBA)
>  /tmp/hda2                1335    1351    136552+    82    linux swap
>  /tmp/hda3                1352    1989    5124735     82    linux
I guess that is 82 and not 83 (ie linux native)
>  /tmp/hda4                1990    2372    3076447+    83    linux
>  ( why fdisk reports /tmp instead of /dev ? )

Do you have the device files in /tmp (shudder !) by any chance ?
Which distribution are you using?

>  my PC has a WDC WD204BA hard disk (20.4 GB). I went to the wdc web page and
>  the closest model I found was WD205BA that has the following specs:
>  cyls 16383        <---------- DIFFERENT!
>  heads 16
>  sec/track    63
>  the cyl numbers don't match. Is it necessary to correct this?

Better not change it as the kernel has recognised 255 x 63 x 2482 x 512
= 20.4 GB.

>  Also, lilo wasn't installed (to boot linux I need to use the floppy).

You can't install lilo as your first linux partition starts at cylinder
1352 (> 1024). As others have suggested you can load linux from dos. 

There is another trick that uses lilo and avoids booting
dos. Mount your dos or windows partition /dev/hda1 on, say, /dos and
copy /boot to /dos/boot (use cp -a). Then rm -rf /boot. Copy your kernel
image vmlinuz to /dos/boot if it is not already there. Now make a
symbolic link

# ln -s /dos/boot /boot 

and set up lilo as if your kernel image is in /boot. ie set /boot/vmliuz
as the boot image and /dev/hda as boot device in lilo.conf. Run
/sbin/lilo as usual, and I think you will be able to boot linux now. 

This idea is taken from  /usr/src/linux/Documentation/ide.txt  
I haven't tried it myself, so no guarantees. 


Next Technical Meeting: March 11 (Sat) 13:00 Temple University Japan
* Topic: "What's new in Perl 5.6"
Guest speaker: Simon Cozens (TLUG Perl guru)
Next Nomikai Meeting: April 20 (Thu) Linux Conference 2000 Spring Ed.
more info:        Sponsor: Global Online Japan

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links