Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [tlug] Hung Startup

I wanted to thank everyone who took the time to reply.  The actual message was posted late as it came to TLUG's servers from another mail account despite being created on my TLUG member account.  I think that there must be a crossed wire somewhere in Thunderbird, which has gotten nothing but updates for over 20 years.  My TLUG member account lives there with several other versions of myself, including my Tokyo PC Users Group account that hasn't had a hit since about 2007.

I'm going to try to respond to everything once.

During the intervening time, I heard back from a Customer Service rep at ASUS Taiwan, who suggested that their native video drivers for Debian were found by early adopters to work much better on a 'Buntu variant than a pure Debian one and that , unlike an install of the drivers in Debian, which requires manually editing a couple of conf files, installation on 'Buntu variants was simply download, install, and reboot.  He suggested that I consider concentrating on getting right with 'Buntu + the desktop of my choice than continuing to get beat up by Debian.  So, I returned to Lubuntu and found that I was still having problems with the OS remembering basic configuration and was not able to initiate sync in Firefox.  As Jim noted, you can uninstall the snap version of Firefox and switch over to a PPA version.  When I did so, nearly all of my problems disappeared and I had my saved Firefox configuration back and running in less than two minutes.  The upside was that a lot of other performance and configuration issues also stopped immediately.  The CPU+GPU Radeon combination produces the most clear graphic output I have ever seen and I will play with the tweak instructions ASUS sent me later this week.  There is still an issue with fan controllers on the video card, which is a "known problem" and it appears as though installing the one patch mentioned in the online help will require me to brush up on my Python.

So, after, maybe, two hours of work I am where I thought I would have been ten days ago.  Couple of things to note:

- Installing ASUS's drivers and firmware on Debian LXQt and running tests with xrandr produced almost constant failure to find and set gamma on my particular video monitor / video card combination and it kept trying to set the refresh rate to nearly double the known required level (137.5 vs 60Hz).  Running the same confirmation tests on Lubuntu yielded expected results immediately.

- I tried several different Debian installs -- no-desktop, XFCE, LXDE, LXQt, KDE.  None recognized my video as 1920x1080 and all required extensive manual reconfiguration to start and run reliably.  When you're four hours in and the Internet instructions say there are "just" 26 simple steps left, you question your motives.  In most cases, I had to do a full install because the Live CDs were hanging with "st5100-tco Watchman not working" (sic) errors that stopped the loading.  All-in-all the Debian installation sets seem to be not ready for Prime Time for someone interested in installing, configuring, and forgetting.  Also, the selection of supporting software, particularly Bluetooth, audio and video players, and office support programs all look like stuff scraped out of the back of closets or left over school programming projects.  I guess that mainstream supporting programs is another big "other reason" why I went back to a 'Buntu in the end.

-  As Steve notes, the workaround for the CUPS hang is Ctrl+Alt+F3, login, then type "startx" to get in.  But, once in, I was never able to pin down the cause of the CUPS hang as it appeared to be a failed dependency issue I was unable to isolate.  I hadn't considered uninstalling CUPS but, after reading through the startup log it seemed as though messing with it would be kicking out the third leg of the stool and everything would fall down.  I might have been exaggerating that given the number of tries and fails I'd already faced.  As for the dead keyboard I mentioned -- neither the USB or wireless keyboard (I had both running) would work.

-  Finally, I beg to differ with Steve's assertion that all install media are the same except for the desktop.  I quickly learned that the installation wrappers used by the installation disk creation teams of the different Debian flavors are not all the same.  There is one particular wrapper universally used by all 'Buntu versions as all of them now automatically offer UEFI disk partitioning.  But, the same wrapper is only available in a couple of the Debian variants and I counted at least four variations.  Finally, the Debian graphical installer continues to hang on all of my systems, as it has for many years, at the "configure connection" and, I think the cause is the missing rtl hardware driver which always needs to be installed manually. Installing from a "+ firmware" disk set finally got me around that issue.

-  Oh, and Mint?  No thank you.  I was an early adopter back when they wanted you to re-format your HDD for every "upgrade" and that meant saving to a separate disk or saving all of your work and putting it back.  I left and never went back.

On 8/29/22 17:25, Stephen J. Turnbull wrote:
CL writes:

  > I have successfully done several installations of Debian Bullseye, using
  > a Debian+Firmware iso to get the RealTek driver installed
  > automatically.  I have tried installing the LXQT desktop,

The desktop is going to be irrelevant to everything except the splash
screen.  Changing desktop is not going to

  > This occurs before keyboard and mouse drivers are mounted so reset
  > options are limited to the large friendly button on the box.

I doubt that's correct.  There may be no mouse driver, but there's
always a keyboard driver in the kernel.  So I suspect that you're
actually seeing a kernel panic.  Once you get access you should be
able to check the logs to find out more about what happened.

You should be able to escape from the GUI bootup by hitting a function
key (maybe F2 but I'm not in a position to check) within a second or
two of the boot sequence starting (this is not for the BIOS, this is
to interrupt Linux's own GRUB bootloader).  Use apt-get or dpkg to
force-uninstall CUPS, and see what happens from there.

If you can't do that, you should be able to do something using a live
boot disk.

Home | Main Index | Thread Index