Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[tlug] Dealing with a possibly busted external HD


Doing some spring cleaning I found an old (5 years) backup external disk, and
tried to plug it up.

The disk would not mount (with the extremely unhelpful "no permission" message),
and when I noticed the led light blinking, I tried dmesg:

[29525.046953] Buffer I/O error on dev sdc1, logical block 471859272,
lost async page write
[29525.338820] sd 6:0:0:0: timing out command, waited 180s
[29525.338843] sd 6:0:0:0: [sdc] tag#0 FAILED Result: hostbyte=DID_OK
[29525.338848] sd 6:0:0:0: [sdc] tag#0 Sense Key : Hardware Error [current]
[29525.338853] sd 6:0:0:0: [sdc] tag#0 Add. Sense: Internal target failure
[29525.338859] sd 6:0:0:0: [sdc] tag#0 CDB: Write(10) 2a 00 e1 00 04
48 00 00 30 00
[29525.338862] blk_update_request: I/O error, dev sdc, sector 3774874696
[29525.338869] Buffer I/O error on dev sdc1, logical block 471859329,
lost async page write
[29525.338882] Buffer I/O error on dev sdc1, logical block 471859330,
lost async page write

I guess this means this disk is busted beyond hope, right?

Some questions:

* This was a backup disk, and I still have the data, so I don't need
to recover anything. But I'd like to clean it up before throwing it
away to make sure someone more hardware savvy than me cannot recover
anything. Any suggestions?

* The disk dying after 4 years of inactivity seems to kinda defeat the
purpose of a backup disk :-/ any suggestion on how to avoid this
happening in the future? (The disk was left on a shelf in a room, and
only exposed to dust)


Claus Aranha

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links