Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [tlug] Self-introduction + thank you for scanner help

On Sun, 28 Jun 2015 18:27:03 +0800, Raymond Wan <> wrote:

> I'm running Ubuntu and it's good enough for me to do what I need to
> do. But none of scanner, printer, nor webcam work... Yes, I could fix all
> of them and the reason is I'm too lazy... But no, they definitely
> don't work out of the box.

Since my "expertise" is much closer to Thomas' than the rest of you
Linux cognoscenti, may I be permitted to add something just in case
he isn't aware of it yet.

Brands matter. I never did get my Epson or Canon printer/scanners to
work on Linux. I gave them away.

With a _lot_ of help from this list, especially from Stephen Turnbull, I did
manage to get my Brother printer/scanner working on Linux Mint 17
Qiana here in Japan. (The printer was easy. The scanner was not.)

Connected to my machine in Montana, I have an HP all-in-one. Getting
it working on Mint 17.1 Rebecca was as easy as Windows. Maybe easier,
I don't remember Windows all that well. Ran one script for everything --
both printer and scanner. And they worked immediately.

I would like to take this opportunity to thank the list and apologize for
being so late in doing so: it has been a busy year what with retiring from
the university here in Chiba and building a new house in Montana.

Stephen suggested that my scanner installation problems on Linux Mint
seemed to be carrying over something from a previous installation. I
had kept "/home" separate and mounted it with everything from the prior
installation (kinduva lazy thing to do) and so I reinstalled Mint completely
fresh, no carry-overs.

I also ran a memory check and found some bad memory.

So, after the re-install everything almost works as it should, and does
work well enough for my purposes.

Strangely enough, I could only use the scanner as root at first, despite
having set up a group and done what I knew how to make it available.
But. When I run gimp (_not_ as root), it detects and uses the scanner. If
I cancel the scanner request in gimp (by closing gimp) before it completely
sets up the scanner, I get the same error message that I get trying to run
the scanner from a terminal without "sudo". Weird. But it works, so I have
no incentive to "fix" it.

Anyway, sincere thanks to the group for your patience and help to
this non-computer-geek.


Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links