Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [tlug] Ubuntu 13.10 clock problems (was: Ibus and Ubuntu based)

On Thu, Nov 7, 2013 at 6:45 AM, Bruno Raoult <> wrote:
>> Well, in more detail, the specific problem I had was that although the
>> clock was showing the correct local time, when I copied some photos
>> over to the computer (from an SD card reader), it changed the
>> *metadata* of the photos in the process (Very Evil behavior in my
>> opinion) and so the matadata on all the photos was shifted by... ten
>> or eleven hours.
> If you just "copied" the files, this is just impossible.

Um... it happened, so it appears to be (unfortunately) possible....

> How did you copy the files? With a photo program, or just a simple copy?

Dolphin - it's always worked well for the same procedure before, but
it changed the metadata when I copied the files over via a Live-CD
(correct term?) version of Kubuntu (latest LTS version).

> I have a couple of questions on what could have happened:
> Did you check meta-data on the SD card with the Linux system? Or did you
> compare the time with 2 different systems (for instance the camera itself, and the
> Linux system)?

Accurate metadata within the camera - inaccurate after copying over to
the computer via Live-CD/DVD.

> Which format are the pictures? jpeg?


> Does your camera have a GPS, and/or the notion of timezone?


>> I made a wild work-around to fix the issue (too convoluted and analog
>> to mention here) that fixed the issue of losing the accurate date and
>> time information that goes with the pictures, but not the computer
>> problem of mutating mata-data simply when copying photos over to a
>> hard drive....
> exiftool would change the time(s) of all your pictures with a single
> command, but I doubt you have to do it, as the pictures meta-data was not
> changed (if you copied them "normally").

Not sure what you mean by "normally".  What I did was highlight, drag,
and select "copy" (within Dolphin).

> Could you send us the metadata of one file on the SD card and on your Linux
> box after the copy? I mean as shown by the Linux box.
> You can get it with the command "exiftool" (or others, there are many).

I've since shifted that work to another computer, but (when I find
time), I'll try to reproduce the problem and post some examples.
Actually, I understand you saying that that... *should be* impossible
when just copying files - and it's never happened to me before in
almost 20 years of copying files (on a steady and regular basis over
that whole time) from several digital cameras over to various
computers running various types of software, but it happened as I
described, and happened several times.  I didn't catch it at first, as
I also thought that would be impossible, but after a few batches, I
noticed a wrong date, and when I checked the different batches, it
correlated with using that Live-DVD to perform that task, and when I
tried it again, that was the result.

In any case, I'll try to get some evidence for you, but I'll need some
time - I've got a load of other things to get done at the moment.


Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links