Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[tlug] MySQL behaving strangely


I'm going through the post-hard-drive-crash process of reinstalling everything, and MySQL is acting very strange.

I installed it as I always have done, but using Ubuntu's Synaptic Package Manager to install all the default packages for a LAMP server. Every time before I've done this it has worked like a dream.

It seemed to work when I first installed it yesterday, but today, when trying to access phpMyAdmin, I got this error:
#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)

I figured I'd give MySQL a bit of a kick just to see if that would help:$ sudo /etc/init.d/mysqld restart

But it gave me this new and unusual response:

sudo: /etc/init.d/mysqld: command not found

Huh. Weird. But I thought it was running, so I ran:$ ps aux | grep mysql

And it said back to me:

root 11171 0.0 0.0 1772 532 ? S 20:36 0:00 /bin/sh /usr/bin/mysqld_safe
mysql 11290 0.1 0.7 126708 15424 ? Sl 20:36 0:00 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/ --skip-external-locking --port=3306 --socket=/var/run/mysqld/mysqld.sock
root 11291 0.0 0.0 2920 736 ? S 20:36 0:00 logger -p daemon.err -t mysqld_safe -i -t mysqld
dave 11309 0.0 0.0 3004 764 pts/0 R+ 20:37 0:00 grep mysql

I'm obviously no expert (closer to babe-in-the-woods in the grand scheme of things), but it looks like MySQL is running in some kind of safe mode or something?

I tried rebooting, which is how people who are clueless like me pretend problems can be solved, and it still came up the same, indicating that this safe mode seems to be locked in.

Any ideas why it is doing this, and how to get MySQL happy again?

Dave M G

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links