Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [tlug] debian testing network setup

Hash: SHA1

On Tue, Nov 30, 2004 at 02:23:08PM +0900, simon colston wrote:
> I installed debian testing by installing stable first and then apt-get 
> dist-upgrade, after setting the sources.list appropriately.  This all 
> went fine.
> I then upgraded the kernel-image to 2.4.27 but after I rebooted I could 
> no longer connect to the network.
> I tried:
> # ifup eth0
> and got a "device not found" error.
> I checked out the /etc/network settings and they seem fine, and they 
> were working OK for the 2.2 kernel.
> I've tried googling for "debian 2.2 2.4 kernel upgrade" and the like but 
> without luck so far.  Where should I start looking for the problem?
> Hardware:
> P4, Intel 865G chipset, RealTek RTL8101L on-board LAN.

This might be the thing I mention on my Debian page (although in my
case, it happened in the 2.6 kernel)  They have the tcp_ecn flag set by
default.  You might be able to fix it with

sysctl -w net.ipv4.tcp_ecn=0

(Then, recompile the kernel, removing the flag).

- --

Scott Robbins

PGP keyID EB3467D6
( 1B48 077D 66F6 9DB0 FDC2 A409 FA54 EB34 67D6 )
gpg --keyserver --recv-keys EB3467D6

Willow:  I mean, please.  Does Angel come up to Faith's standards
for a guy?  Let's see, is he breathing?
Buffy:  Actually, no.
Version: GnuPG v1.2.6 (FreeBSD)


Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links