Mailing List Archive


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[tlug] Trouble with iPhone tethering over USB



TLUG friends... I'm hoping with all the tech talent here that someone
can give me a clue to get beyond this.

Trying to tether my Gentoo laptop to my iPhone (5s, 11.2.1 - latest)
over USB. Everything SEEMS to be in order, so I won't bore you with ALL
the details... on the laptop side kernel and userspace mods have been
installed, a new interface for the phone connection is created... when I
plug in the phone via USB, turn on Personal Hotspot, and bring up the
interface on Gentoo, it gets its IP and routing info via DHCP (a private-
space address under 172.16.0.0 for the USB subnet). And /etc/resolv.conf
gets updated accordingly (phone as nameserver). So far so good. Also
note that during testing all other possible network connections are
completely disabled.

The problem is, that I can't seem to reach anything in the outside
world, via browser. If I try to load any site, it spins until I get a
timeout. I can ping the router (phone) side, but if I try to ping
outside sites that I know respond to ping, I get nothing back.

But now here's the weirdest thing of all: If I do this:

  $ telnet www.google.com 80
  GET /

I can connect, and get a response! Same for several other sites
I've tried that refuse to load in the browser.  I've tried sites
with no https, and the result is the same, so it doesn't seem to be
related to that.

I really need to get this working soon, so any help is very much
appreciated. And you have no idea how much I regret missing that
b┼Źnenkai with all the great-looking food :=)

Dave


Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links