Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [tlug] Scanner not found

It has been well over a week, and today is the first chance I've had to

even look at this. The day after I got the above email started with taking

my wife to ER. (Turned out to be gallstones.) It has been hectic since.

Anyway, I am back on this (still unsolved) scanner problem now.

To recap:

> I get "Failed to open device 'brother3:bus4;dev1':

This appears to be the address of the USB hub you're attaching to.

> Invalid argument."

Yup, the hub is not a scanner.

> Funny thing is, when I run "lsusb" I get "Bus 003

> Device 002: ID 04f9:01f2 Brother Industries, Ltd."

To proceed:

Stephen J. Turnbull writes:

> If you *still* don't have a scanner, send me (or the list) all the

> info you've gathered about, preferably cut and paste from the 'term.

> OK, so your 40-libsane.rules has an entry like this:
> # Brother MFC-6490CW
> ATTRS{idVendor}=="04f9", ATTRS{idProduct}=="01f2", MODE="0664", GROUP="scanner", ENV{libsane_matched}="yes"

My entry is as follows:

# Brother scanners
ATTRS{idVendor}=="04f9", ENV{libsane_matched}="yes"

Compared to your example, it looks as if I may need to flesh it out some.

> Next make sure that your Brother driver is listed in
> /etc/sane.d/dll.conf. You may want to comment out all the scanners
> you don't have (saves some startup time). This name must correspond
> to a filename like /etc/lib64/sane/ (ie, drop the
> path, the "libsane-", and the .so as well as any version numbers after
> .so). If all that seems to be in order, and things still don't work,
> keep going.

My dll.conf file lists nothing as specific as your example. It is as follows:


# /etc/sane.d/dll.conf - Configuration file for the SANE dynamic backend loader


# Backends can also be enabled by configuration snippets under

# /etc/sane.d/dll.d directory -- packages providing backends should drop

# a config file similar to dll.conf in this directory, named after the package.


# The next line enables the network backend; comment it out if you don't need

# to use a remote SANE scanner over the network - see sane-net(5) and saned(8)



… [loooong list of scanner names omitted]



Since the “brother3” is at the bottom and not in alphabetical order, and has a

blank line above it, I assume it is an add-on. But, it doesn't have any path or
version numbers or anything else listed.

> So, first, reboot. (Sorry.) Next try "sane-find-scanner" from the

That got me:

" # No USB scanners found."

> Then try "scanimage -L".

This does find the scanner.

"device `brother3:bus4;dev1' is a Brother MFC-6490CN USB scanner"

At the address that you previously suggested was probably a USB hub.

> If not found, try "scanimage -L -d=brother3:/dev/bus/usb/003/002" and
> see if that helps.

This gives me exactly the same result as "scanimage -L"
Despite having ".../usb/003/003" it identifies the device as

> error, so try "scanimage -h -d=brother3:/dev/bus/usb/003/002" and see
> if it tells you all the wonderful options available with your Brother
> scanner.

It does indeed!

After all those wonderful options are listed, though, it gives this error:

scanimage: open of device =brother3:/dev/bus/usb/003/002 failed: Invalid argument
Type ``scanimage --help -d DEVICE'' to get list of all options for DEVICE.

List of available devices:

I do appreciate the help! Do you have any suggestions as to what might
resolve the issue of failing to open due to invalid argument?

Apologies in advance for trying your patience with my non-computerized mentality.


Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links