Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[tlug] Ibus and Ubuntu based

Ok, Lyle and I have had some bad experiences with iBus, but we're only two

Have people on this list installed a fresh 13.10 Ubuntu or variant, and
found that ibus works as well as it has in the past?  I just tried on
Lubuntu 13.10 64 bit to find that it has become pretty useless.   

Several stupid, in my less than humble opinion, design changes--changing
the ctl+space, that has been in use since kinput2-canna days for
super+space, which breaks with various desktops--for example, in dwm, it's
hardcoded in dwm's config.h to change layouts.  This one is easily changed
during ibus-setup. 

Then, one one clicks to add languages, non-Latin character languages, at
leats in Ubuntu variants, don't even show.  One has to first click show all
languages, which closes the dialog box, then click the whole add language
thing again. 

Ok, all these are minor and cosmetic, and probably only really troublesome
to the inexperienced.  Frankly, since Fedora has started catering the
inexperienced with the RH people blithely adding these changes to their
server systems, I don't care about them, and time and time again see it
being a perfect example of forgetting the statement that Unix doesn't keep
you from doing stupid things because that would also keep you from doing
clever things.

At any rate, my big problem is that even after going through all this, it
no longer works in Lubuntu--the only Ubuntu variant I've tried. It's
possible the developer only tried it with Unity--I remember in Fedora that
at one point, if you hadn't installed Gnome, ibus wouldn't work because it
needed something that Gnome installed but openbox didn't--dbus-x11, IIRC. 

However, at least in Ubuntu, it simply doesn't work.  Hitting ctl+space
(after changing that to be the default) will give me a nice hiragana "a"
icon at lower right, but no ability to input Japanese.  It's a shame as for
awhile, I was putting Lubuntu on the laptops of a few of my wife's friends
who had older computers that were virus infested, but it looks like I'll
have to try something else. 

I'm sure it is fixable, and will probably be fixed, but at present, not
worth my effort.  I am wondering though, if this is a wide spread problem
or just confined to a few.

Scott Robbins
PGP keyID EB3467D6
( 1B48 077D 66F6 9DB0 FDC2 A409 FA54 EB34 67D6 )
gpg --keyserver --recv-keys EB3467D6

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links