Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [tlug] Oh, permissions, how I love constantly fighting thee

Hi Dave,

On 31/01/11 14:45, Dave M G wrote:

I'm trying to download a tar file from my server using the command ncftpget.

It logs in successfully, finds the file, and then says:

Cannot open local file //backup_20110130_-_212227.tar.gz for writing:
Permission denied.
ncftpget *.tar.gz: could not open file.

So, I logged into the server and changed the permissions on the tar file
to 777. Still no joy.

Then, I checked the permissions of the local directory I'm downloading
to, and made that 777 for the moment. And yet still no joy.

Whose permissions are not being permitted?

Any advice would be much appreciated.

Well, if you're downloading to a subdirectory, then you need permissions at every level above it. But it seems like you're downloading to "/"? Using sudo? I guess a normal user can't download to there...have you tried downloading it to "/tmp" (even though it's probably too big to fit).


Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links