Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[tlug] Help! Total hardware failure


My main desktop computer where I do all my work has completely crashed on
me. It won't boot.

I have back ups of data, but of course it would be a lot better for me if
I didn't lose all my more recent work. Back ups are never as recent as you
want them to be.

Here's what happened:

I rebooted the machine, for no particular reason. Sometimes I do that,
more for myself than for the machine. I think it's an old Windows habit,
to just reboot and start fresh now and again, just to clear out any old
processes or whatever. Probably not needed with Linux, I know. But the
point is that there was absolutely no sign of impending doom. My computer
has been running like a dream for ages now.

This time when it boots up again, there is a clicking noise. Not a beep or
anything like that, but a mechanical clicking noise. I wait, and the
computer doesn't go past the POST screen.

I turn off the power, open up the side panel, and boot again. Now I can
determine that the clicking noise is coming from the hard drive. I wait
for a while and eventually I get this message:

Reboot and Select proper Boot device
or Insert Boot Media in selected Boot device and press a key

Crap, I think, my hard drive has died.

I put in an Ubuntu boot CD, thinking maybe I can run some kind of
diagnostic or at least access the data, or something.

It initially comes up with the screen to select what action you want to do
(boot from CD, install, etc...), but after selecting to run Ubuntu without
changing the computer, it tries to boot for a long time and then
eventually I get error messages that look like this:

SQUASHFS error: Unable to read fragment cache block [2662784b]
SQUASHFS error: Unable to read page, block 2662784b, size d843
Buffer I/O error on device sr0, logical block 315578
SQUASHFS error: sb_bread failed reading block 0x998

It repeats these errors over and over again for ages, until finally it says:

run-init: /sbin/init: I/O error
Kernel panic - not syncing: attempted to kill init!

Then it stops all activity.

I can't get any Linux interface, GUI or command line, even if I boot from
CD. I also tried physically removing the hard drive, booting from the CD
again, and I still get all the SQUASHFS errors.

So now I'm not so clear on whether the problem is the hard drive itself,
or some kind of connection to the hard drive that would also effect the CD

I want to proceed very carefully and figure out what's going on here.

Priority one is securing the data on the hard drive. I have a second
computer, but it doesn't seem to have a SATA connector (It's old).

So if nothing else, I'm wondering if there's anyone who can help me hook
up this hard drive and copy some data over to some DVDs or something. Or
recommend somewhere I can do that. Assuming, of course, the drive is

If not, can hard drives be repaired? Where would I go to do that?

Second priority is figuring out what's wrong with the computer and fixing
it. Is it the hard drive? Is it something else? What can I do from this
point to be sure about what's going on?

Thanks for any advice or help. My life is pretty much on hold until this
gets sorted, so I hope I can get this sorted ASAP.

Dave M G

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links