Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[tlug] USB mounting problems in newest Debian Sarge

I don't know if anyone has done any very recent Sarge installations,
but they've slightly altered the device naming / mounting of the
external drives in a way that the prior methods for mounting don't
seem to work. I'll sign onto the Debian-user list for a while if
necessary, but figured I'd check with TLUG'ers first.

I have two 20 GB exernal drives, one SCSI and one USB. With prior
installations, I used to end up with an arrangement like this in my
FSTAB, wherein I was able to mount either drive as I liked in the
normal way:

    /dev/sda1 /mnt/scsi vfat noauto,users,exec,umask=000 0 0
    /dev/sdb1 /mnt/usbdrv vfat noauto,users,exec,umask=000 0 0

But the new Sarge installer sets me up with something like this (I am
just dealing with the USB drive at the moment--I haven't tried to
figure out the SCSI drive), where the last line refers
to my external USB drive:

    # /etc/fstab: static file system information.
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/hda8       /               ext3    defaults,errors=remount-ro 0       1
    /dev/hda9       none            swap    sw              0       0
   /dev/hdc        /media/cdrom0   iso9660 ro,user,noauto  0       0
   /dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
   /dev/sdb        /media/usb0     auto    rw,user,noauto  0       0

When I tried to mount it, first I got this:$ mount /media/usb0
     mount: I could not determine the filesystem type, and none was specified

I Googled this error message, and found the expected recommendation to
supply a filesystem type. I added vfat to FSTAB instead of AUTO, but
got the same error message. I then tried to do it on the command line:$ mount vfat /media/usb0
       mount: only root can do that

OK, so,$ su
       Password: *******
       xps8250:/home/chuck# mount vfat /media/usb0
       mount: special device vfat does not exist


      xps8250:/home/chuck# mount /media/usb0 vfat
      mount: mount point vfat does not exist

Then again,

       xps8250:/home/chuck# mount /media/usb0
      mount: you must specify the filesystem type


      xps8250:/home/chuck# mount -t vfat /dev/sdb /media/usb0
      mount: wrong fs type, bad option, bad superblock on /dev/s                   db,
       or too many mounted file systems

Any ideas?



Charles Muller  

Toyo Gakuen University
Faculty of Humanities  
1660 Hiregasaki, Nagareyama-shi
Chiba 270-0161 JAPAN
Mobile Phone: 090-9310-1787

Web Site: Resources for East Asian Language and Thought

(remove underscores before using)

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links