Mailing List Archive

Support open source code!

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Gnome and kinput

Quoting Viktor Pavlenko <>:

> >>>>> "JG" == Josh Glover <> writes:
>     JG> [...] Or install any Japanese input method
> into
>     JG> Emacs? Currently, when I try to switch input
> methods,
>     JG> Emacs finds none.
> You have to get the leim emacs package installed. I
> downloaded both
> emacs _and_ leim source, compiled it, and the input
> methods I tried
> (including Japanese) work fine. Maybe you can do
> this with rpm too
> (never tried).

Thanks for the tip. I got leim installed from rpm no
problem, but then I was back to the situation that I had
been many months ago when I was trying to get Japanese to
work with emacs: the input methods seem to work, but the
kanji and kana does not display. I see only boxes the colour
of my background with white lines around them, roughly the
size of one kana a piece. These change colour when I convert
my kana to kanji. For example, I type in "nihon," which is
converted to hiragana (that I cannot see), then use the
space bar to convert the hiragana to kanji. When I hit the
space bar, emacs reports that it is loading the skk kanji
conversion engine, which succeeds, then the three boxes
become two (two kanji, you see) and change colour. When I
save the file and then cat it in a kterm, I see the kanji
"ni" (two) and then "hon" (book). Obviously, this is the
kanji dictionary's first choice for "nihon." So, input is
working fine, but I cannot see what I am inputting.

Has anyone ever seen this, or know what might be causing it?
I rather suspect the emacs-X11 package, but I do not know
why kanji will not display in emacs, because I have no
problem seeing kanji in gjiten or kterm, so my Japanese
fonts must be installed and working, right? I am running
XFree86 4.0.1, Gnome 1.2, and Sawfish 0.30.3 on the X side
of things.


Josh Glover

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links