Mailing List Archive

Support open source code!

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

everything broken

Stephen J. Turnbull" wrote:

> The great thing about Linux is
> that when it breaks, you can post to TLUG and someone will tell you
> how to fix it.

Okay,  here we go.
My ultimate goal (as I've been whining here before)  is to have a 6x86
optimized system.  I was aiming for athlon optimization though.
Anyway, last week I tried to compile gcc, but what do I see: gcc 2.95
(gcc version 2.95.2 20000220) can't even compile itself.
I pulled gcc from the cvs, that would compile but the athlonGCC pach did
not like it, and also I wanted to create a binary deb.
So last night I did again "apt-get source --compile gcc". This time the
compilation went further (choked on something else), but still not all
the way.
Ok,  so I gave up with gcc.  Next, lets compile glibc. This is what the
configure script spits out:
"checking installed Linux kernel header files... TOO OLD!"      (khmm, I
have 2.4.0-test11)
I looked into the configure.log:
"configure:30: gcc -c  -nostdinc -isystem
/usr/lib/gcc-lib/i386-linux/2.95.2/include -isystem
/usr/src/kernel-headers-2.2.15/include  conftest.c 1>&5
configure:22: linux/version.h: No such file or directory"
And that's where I got pissed even more. Why in the world can't they
just put the path /usr/src/linux/include/  in the **** script!? AFAIK
this is the path to the kernel headers (any version).
And there is tex/xdvi which I can't get to work, I will probably end up
doing my Japanese word processing under vmware/msword (oh, puke).
Next, I was hoping to be able to use XFree 4 (the xserver), but xawtv
doesn't work:
    This is xawtv-3.24, running on Linux/i686 (2.4.0-test11)
    visual: id=0x21 class=4 (TrueColor), depth=24
    visual: id=0x22 class=5 (DirectColor), depth=24
    Xlib:  extension "XVideo" missing on display ":1.0".
    x11: 1024x768, 32 bit/pixel, 0 byte/scanline
    WARNING: Your X-Server has no DGA support.
    WARNING: couldn't find framebuffer base address, try manual
             configuration ("v4l-conf -a <addr>")
Tried the manual config with v4l-conf, but after this xawtv just put
garbage all over the screen.
How can I get DGA to work under XFree-4? Or is it just xawtv unable to
recognize th support?
And what do I need for these:
    Xlib:  extension "SHAPE" missing on display ":1.0".
    Xlib:  extension "XVideo" missing on display ":1.0".

enough for now (though I still could go on...)

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links