Mailing List Archive

Support open source code!

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[tlug] Help! - I broke dhcp

Sorry to bore you all, but I need some more specific RH7.2 help.

The networking aspects of RH7.2 installed and worked fine on my T2800. I
took it home, plugged it into my home hub (hangs off a cable modem),
installed my ISP's logon client (3rd party rpm from local Linux people)
and it worked fine there too.

The only trouble at home was the hostname became the automatically
assigned one from the ISP: "CPE-VIC-PIGBOND-blah-blah-blah..." Looks
great on every xterm and kterm. So I fired up the N/W config tool, and
hunted around for a hostname. The tool on the Start menu is different
from the RH7.1 one, but it had a panel with a Hostname entry, in which
was "localhost.localdomain", and the ISP's DNS servers were listed as
well by IP address. I changed the hostname to my usual local hostname
and thought nothing more about it.

This morning - disaster. It wouldn't even start X, saying it counld,'t
find that host. I started X by hand (startx) and found the screen and
put localhost.localdomain back in, but on rebooting I can't seem to get
the DHCP to contact the ISP. From the stuff in /var/log/messages it
doesn't look as though DHCP even ran.

The RH7.1 netcfg has a panel about DHCP and you can force it to run from
there, but that seems to have vanished with RH7.2

No-one around here has much RH7.2 experience. Any suggestions? One
suggestion I got was to remove dhcp and reinstall it. All I want is the
defaults back.


Jim Breen  []
Computer Science & Software Engineering,                Tel: +61 3 9905 3298
P.O Box 26, Monash University,                          Fax: +61 3 9905 5146
Clayton VIC 3800, Australia      ジム・ブリーン@モナシュ大学

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links