Mailing List Archive

Support open source code!

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

php3's enable versioning

Is anyone using --enable-versioning with php3 [1]? It is used to allow
php3 and php4 modules to co-exist in apache. I've got this combination
working on an RH machine, and did have it working on my Debian machine,
but now when I try to use it I get this error:

  Syntax error on line 69 of /usr/local/apache/conf/httpd.conf:
  Cannot load /usr/local/apache/libexec/ into server:
  libexec/ undefined symbol:

That is all - there is nothing after the undefined symbol. This is with
pgsql, i18n, etc. But it happens even if I use a bare-bones configure,
except then the undefined symbol is "C". I've tried a rebuild of apache
and then php3, and it still happens.

The only thing that has changed since it was working was upgrading some
Debian packages. But binutils didn't change then (it's,
which seems to be the important thing for --enable-versioning. [2]

Anyone have any thoughts?


[1] apache 1.3.14, php 3.0.15-i18n-ja

[2]:locales_2.1.3-13 was installed. Just tried removing that and
recompiling, but no change. "locale" says "C" (normal user) or "POSIX"
(root). On the working RH machine both users say "en_US". Is that

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links