Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[tlug] USB HDD Startup

My Lubuntu 19.04 machine has three attached 4Tb USB 3.1 external HDDs, formatted HTFS.  They are reformatted from their original factory formatting with Gparted and named with sequential numbers -- 3,4,5.  Two plug directly into USB 3 connectors on the motherboard and one into a USB 3 add-on card in a PCI16 1x slot.  I have entered all three of them in my fstab file, identifying them by their UUID. They have booted properly for over a year in this configuration.

Recently, HDD 4 -- connected to the motherboard USB 3 connector -- refused to boot properly and the system hung as the startup routine tried to start it, first by location name, then UUID.  I started the system using a Lubuntu Live DVD, then ran KDE Partition Editor.

The file manager could see the HDD plugged into the add-on card but could only see whichever of the HDDs was plugged into the left-hand (viewed from the back of the machine) motherboard connection.   HDD 4 was viewable once, but file manager said it had no files saved on it when it had been about 70% full before rebooting.  Put it on a box with a WIN10 virtual PC on it.  It couldn't be read by either the Debian host or WIN10 guest until the box was rebooted.  Then it was seen, but could not be read, so I ran chkdsk /f, which reported no problems and made the contents visible.  When I returned the disk to the Lubuntu box, plugging it into the motherboard USB 3 connector, it was readable, so I rebooted ... and it would not load, dropping me into repair console.  I commented out the startup information for HDD 4 in fstab and rebooted.  I promptly had a clean boot and the HDD was visible, readable, has all files visible, and seems to be running fine.

One strange thing just noted is that the UUID of HDD 4 is no longer the one I used to identify it in fstab but I think it was correct until I ran chkdsk /f on WIN10.  Does WIN rename removable disks?

So ...

1. Do I just ignore this issue and keep using the PC as is?
2. Do I edit fstab, change the UUID, remove the comment out, and restart?
3. Do I worry that this HDD is dying even if SMART has no warning flags visible? 4. Is this an indication that one USB 3 connector on my motherboard will soon pine for the fjords?
5. Can anyone think of a reason for this behavior?
6. 42?


Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links