Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[tlug] Installing from source

My newest brick wall ... I am trying to install claws-mail from source to solve some recurring problems I am having with the "stable" version.  I need to:

- upgrade from 3.14.1 to 3.17.1

- replace the Fancy HTML parser, which has started not working with the newer version which everyone tells me does

- installing 3.17.1 from a .deb uninstalls and locks out the Fancy plugin and replaces it with Dillo, a parser that has never heard of Unicode.  Suddenly it is 1995 and we're reliving the WIN 95 introduction.

Installing Claws 3.17.1 requires changing the distribution source from stretch stable to stretch-backports and the installation of pkg-config.  It also asks that GLIB2.0 be upgraded to v.2.28 or higher. 

Here is the latest error message to the ./configure command:

Check for GLIB... no
configure: error: Package requirements (glib-2.0 >= 2.28 gmodule-2.0 >= 2.28 gobject-2.0 >= 2.28 gthread-2.0 >= 2.28) were not met:

No package 'glib-2.0' found
No package 'gmodule-2.0' found
No package 'gobject-2.0' found
No package 'gthread-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GLIB_CFLAGS
and GLIB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Synaptic can only deliver GLIB 2.24 in .deb form and the installer is asking for 2.28 or higher.  Debian sources offer three files for downloading and installing GLIB 2.50:




If I download and install these packages, should I expect to finally complete installation?  Do I download and install all three?  I am completely lost as to what to do next. Can anyone offer some easy to figure out guidance?


Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links