Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[tlug] BIOS / Video Problems

First off, I haven't been able to do all of the PC projects I set for myself at the end of the year nor participate in tlug discussions.  On New Years Eve, the person living in the upstairs 1DK apartment in our house didn't turn off his space heater and set a pile of newspapers on fire.  The house was destroyed and the PCs suffered damage.  We're now in a different location and I am trying to get everything working properly again. 

Ii have two PCs, both using AMD FX8370e CPUs but intended for very different purposes -- a basic work machine and a torrenting machine.  Both are in different states of inoperability.  I'm focusing on just one machine today.  I'd like to see whether people who know more than me can offer some suggestions. 

My work machine was working okay until a couple of days ago.  Main problem is that I performed the Debian 8 upgrade from kernel 3.16-04 to 3.16-05 in mid-January and it screwed up my X (KDE Plasma desktop) access -- instead of automatically logging into desktop, it was asking for manual provision of my password then failing to load when issuing "startx."  Being so far behind the curve on work and life, I'd just been selecting a login to v.3.16-04 at the opening menu and promising myself that I'd fix the X issue later.

While working on my second machine, which suffered some water damage (and about which more after this machine's problem is fixed,) I checked its SSD (which is the boot disk for a Lubuntu system) by plugging it into my Debian work PC's second HDD slot.  I booted into Debian, checked to make sure it was visible to BIOS and  then booted and checked for operability and looked through the menu trees for any obvious sign of problem.  I then issued a "Shutdown" command, intending to unplug the SSD and re-connect the backup HDD but it appears to have rebooted, instead, and may have tried to load Lubuntu before I caught it and shut down.  When I re-connected the backup HDD and restarted, I had no video, so I shut down and tinkered with the seating of the video card and the HDMI cable.

When I rebooted, I had video again.  Got a message that I had 27 new upgrades waiting to be installed (can't remember any filenames), so I installed them from the command line and rebooted to make them current ... and got a "No Video Signal" message from my screen.

Currently, I can:

- get a lo-rez video signal only from the onboard video connection
- when I switch on, no POST is seen on the keyboard but I can hear disks starting
- I cannot access BIOS (no keystrokes accepted)
- Machine automatically boots into v.3.16-05 (which does not load plasma desktop)
- Keyboard input is not accepted by the machine until the Debian login prompt.
- Only USB keyboard works.  PS/2 connections appear to be dead.
- I tried to open the DVD drive in hopes of loading a live CD/DVD but it will not open.  Issuing an "eject" command gives a response that ioconfig is incorrect.

I want to:

- get BIOS access back so I can activate the video card
- Activate boot from USB disk or CD/DVD drive.

I believe that if I can rsync the home directory to the backup disk and install a new Debian version, I'll address the login issue, but I still need to fix the BIOS problem first ... right?

In case its important:

This machine is intended to be straightforward and simple with no computational needs beyond recalculating five-year~eight-year P&Ls.  It uses an ASRock 960GM/U3S3 FX motherboard, 16Gb (8 x 2) of memory, has two Toshiba 1Tb HDDs and an Optiarc CD/DVD.  Video is Nvidia (Zotac fanless) with 4Gb of DDR5 memory. USB keyboard (Microsoft US keyboard) and wireless trackball mouse (Logitec). Only other extras are an Innotek USB3.1 internal card driving the two front panel USB ports and a Buffalo USB 2.0 card.

(sent from my daughter's WIN10 All-in-One which is s-l-o-w)

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links