Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [tlug] CPU speed: reported vs. actual

> select "Add to Panel...", and add the CPU Frequency Scaling Monitor.
> Once it is added, click on it, then select either the highest
> frequency displayed or the "Performance" option.

At the moment I've three vague ideas as to the problem:
  1. Something in bios.

  2. CPU is too hot, so refusing to go quicker even when told to. (50 to
60 degrees when I ran the tests; all I've found so far is the CPU
supports a range of 0 to 100 degrees.)

  3. CPU Frequency Scaling Monitor is not doing its job properly.

It seems strange that /proc/cpuinfo only returns the faster speed for
the first of the 8 processors, and still shows the slower speed for the
other 7.

...I've tried the cpufreq-selector commandline tool, which has to be run
as root, and has a --cpu parameter. So I used that to set all 8 virtual
cores to be 1.7Ghz. /proc/cpuinfo confirmed that the change had been
made to all 8 processors now. But the linpack benchmark still took the
same amount of time, and reported 11.0847 GFLOPS (i.e. no improvement).

So, I think I can dismiss idea 3.


Darren Cook, Software Researcher/Developer (About me and my work) (My blogs and articles)

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links