Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [tlug] New Sound Card


    sudo apt-get install build-essential linux-headers-`uname -r`


   sudo apt-get install build-essential linux-headers-'uname -r'

(note the difference of the quotation marks around "uname -r")


2011/1/23 Raedwolf Summoner <>
Sotaro Kobayashi wrote:
> The Ubuntu geek forum is very likely to give you a nice solution
> of this #include header file - driver.h error.

Thanks for the suggestion, Sotaro. I tried that and got a different
set of errors, at least it wasn't complaining about no driver.h.  :)
This time the complaint was
error: implicit declaration of function ‘snd_card_new’

But this was a great place to look, as it had links to other
suggestions as well.

One of them suggested a need to install dependencies, giving the
sudo apt-get install build-essential linux-headers-'uname -r'

Unfortunately, I get stuck here too, with the following error:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E: Unable to locate package linux-headers-uname -r

I just may not be geeky enough to understand the directions.
My first guess was that I need to replace "uname" with a specific
package name, so I tried using the XFiDrv_Linux_Public_US_1.00
name there, but that didn't work either.

When I run the lspci -v command in a terminal, I get three
audio devices listed including the new Titanium X-Fi, which lists
no driver. The other two are both using the HDA Intel driver.
Those 3 entries are as follows:

00:1b.0 Audio device: Intel Corporation Cougar Point High Definition Audio Controller (rev 04)
    Subsystem: ASRock Incorporation Device 1892
    Flags: bus master, fast devsel, latency 0, IRQ 47
    Memory at f4300000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: HDA Intel
    Kernel modules: snd-hda-intel

01:00.1 Audio device: nVidia Corporation GF104 High Definition Audio Controller (rev a1)
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at f8080000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: HDA Intel
    Kernel modules: snd-hda-intel

03:00.0 Audio device: Creative Labs X-Fi Titanium series [EMU20k2] (rev 03)
    Subsystem: Creative Labs Device 0062
    Flags: fast devsel, IRQ 19
    Memory at f4200000 (64-bit, non-prefetchable) [size=64K]
    Memory at f4000000 (64-bit, non-prefetchable) [size=2M]
    Memory at f0000000 (64-bit, non-prefetchable) [size=64M]
    Capabilities: <access denied>
    Kernel modules: snd-ctxfi

I do appreciate the help!


To unsubscribe from this mailing list,
please see the instructions at

The TLUG mailing list is hosted by the award-winning Internet provider
Visit ASAHI Net's English-language Web page:

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links