Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[tlug] help with Red based internet connection


I am writing in the hope that I might be able to solve my problem of
making an internet connection here in Kyoto, where I have been for the
past 6 weeks and will be for another two months. Any assistance would
be greatly appreciated.


I am running Linux Red Hat (2.6.12-1.1381.FC3) on an IBM think
pad. Before arriving in Kyoto, I had no problem obtaining a internet
connection with a lan cable. I would simply plug in the cable before
booting and whether at home, or at the office, or at a friend's with a
suitable connection, my computer would automatically obtain a
connection, provided the cable was connected on boot.

I have arranged access here in Kyoto through So-net. NTT came and
installed a fibre optic connection. However, having plugged in the
cable as shown below and booting, I am unable to obtain an internet



There are two small boxes: Each has an electrical outlet. The first
box Into one comes the fibre optic cable. Out of it goes another cable
and it plugs into the second box at a point labelled WAN. A cable
leaving one of four LAN plugs goes to my computer:  Thus,

                   BOX 1           BOX 2                  -------       
    ------                 |      |--cable--| WAN |
                 |      |         | LAN |--cable-- COMPUTER fibre optic 
----|      |         | LAN |                 --------         | LAN |   
                                  | LAN |                               


I have checked by means of the `Internet connection wizard' to verify
that I am properly configured. Here is what the main status page looks

|                                                                 | |   
    Network Configuration                                      | |      
                                                            | | File 
Profile Help                                               |
|                                                                 | | 
New  Edit  Copy  Delete  Activate  Deactivate                   |
|                                                                 |
| Devices Hardware IPsec DNS Hosts <The active page is Devices>   |
|                                                                 |
|     You may configure network devices associated with           |
|     physical hardware here. Multiple logical devices can be     |
|     associated with a single piece of hardware.                 |
|                                                                 |
| Profile   Status     Device  Nickname  Type                     |
|   x        active   eth0    eth0      Ethernet                  |
|                                                                 |

Clicking on Edit in the display above, I arrive at a page which
indicates that the system is set to obtain automatically IP addess
settings with dhcp.

Clicking on DNS in the display above, I get this page:

Hostname:        localhost.localdomain
Primary DNS:
Secondary DNS: Tertiary DNS:  DNS search path: localdomain

It seems as though I should be connected. HOWEVER, - my browser 
(mozilla) does not connect. That is, it says that it cannot
  find what I have designated as my homepage, namely,
- when I typed into the address line at the top of the browser
  the reply I got was: the connection was refused when attempting to
  contact - when I ran  ping  I got in 
reply: unknown host.

I have run ifconfig and I got this information:

inet ad:


The only even which has intervened since trying to connect in Kyoto
and my last successful connection in Canada is the following.

When I arrived at Ryukoku University and plugged into the network
here, my laptop appeared to me to be unable to boot, for during the
boot sequence the screen went completely blank for what seemed to me
several minutes. Stupidly, I have since learned, I shutdown the
computer. I then tried to reboot. I don't recall all the details, but
in essence, I was informed that I had problems. With no one to ask for
help (the computing person here knows nothing about Linux), I pursued
the various options presented to me on rebooting. One option I was
forced into was fsck. This came with all kinds of dire warnings. I
continued to guess as some options, eventually exited fsck and lo and
behold the laptop booted and everything but getting an internet
connection has work fine since then.

By the way, the reason my laptop would not connect is that, as you saw
above, it is configured to get an IP address dynamically. Ryukoku
University assigns static addresses, I have since learned.

One last piece of information. When I boot, everything on the check
list comes up OK, except of course if the cable is not connected and I
am informed that the connection can not be found and I should
check the cable. If I connect to my router (right term?) here, no such
error message appears. HOWEVER, I now get an error message which I
never previously got. It says:

  error making /dev/isdnctrl:  permission denied
  loading isdn modules             FAILED

So, there it is. Any help will gratefully accepted. Bear in mind that
I am a complete ignoramus about computing matters. Don't be misled by
the things I tried above, I was merely following the advice of others
who are more knowledgeable about these matters than I.

Best wishes,

Brendan Gillon

P.S. If you are wondering how I have an internet connection to contact
you, the reason is that the computing service at Ryukoku has lent me a
laptop to be used on campus. Though I have managed in the time I have
been here to read very haltingly hiragana and am now hard at work
learning to decipher katagana, my laptop at Ryukoku runs on a Japanese
version of windows. I have never used windows. I shall not have access 
to this computer again until Monday.

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links