Mailing List Archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[tlug] Forcing programs to run in another language


My user environment is in Japanese. However, there are two cases when I
want to run a program in English.

One is when I'm sharing my desktop with VNC to collaborate with someone
who doesn't speak Japanese. The other is when I want to report errors to
people who most likely won't understand the Japanese error output (not
to mention it's easier on me to track errors in English than Japanese).

If I want to run a particular program in English, I know I can do that
by simply running it from the command line and adding "LC_ALL=en_CA"
before the command (Canadian English being my preference, if it makes
any difference).

So, for example, if I want to run Deja-Dup (a back up utility) in
English, I run:
LC_ALL=en_CA deja-dup

Recently I've had some trouble with Deja-Dup, it keeps failing and
giving some cryptic errors that I want to report to the developers.
However, because Deja-Dup is initiated at startup, it's always running
in Japanese already.

Okay, fine, I figure I can just go into "System->Preferences->Startup
Applications" (I'm on Gnome/Ubuntu) and ad LC_ALL=en_CA into the entry
for Deja-Dup, and it would auto-start in English.

No such luck. Adding LC_ALL=en_CA in front of any command in the
interface in the Startup Applications causes that application to fail
and not load when logging in.

I tried putting it in quotes, like "LC_ALL=en_CA deja-dup", but that
doesn't work either.

The same is true if I edit any applications in my Applications menu to
run in English (which is the case for when I want to run programs

Basically, anytime I try to set things up so that programs launched from
the Gnome panel or from any settings in the Preferences menu be in
English, it just causes the program to be not found.

Is there some clever way I can get around this?

Oh, I thought about creating a Bash script, where I just have two lines:
LC_ALL=en_CA deja-dup

... and then point to that script, but it fails just the same. It says
essentially the program "LC_ALL=en_CA" can't be found.

Any tips would be much appreciated.

Dave M G

Home | Main Index | Thread Index

Home Page Mailing List Linux and Japan TLUG Members Links